HubSpot Product Updates

[Integrations] - Oauth2 goes into effect 1/19/18

Written by Marcus Andrews | Dec 1, 2017 3:45:31 PM

On January 19th, 2018 we’re deprecating OAuth1 for all integrations. At that time any integrations still using Oauth 1 will break. Most integrations should be on OAuth2 now but to make sure they function properly users will need to re-auth if they haven’t done so already before Jan 19th.

Background:
All HubSpot integrations are built using an authorization token. To improve how integrations work we introduced a new version of this auth token called OAuth2. Over the course of 2017 we have worked with integrators to move their integrations from OAuth1 to OAuth2. Most integrators have rebuilt their integration with OAuth2 and right now you can no longer create, or re-auth an integration that uses OAuth1.

Note - Connect integrations are all clear:
If you use a HubSpot Connect certified integration, you shouldn't need to take action. These integrators have updated their auth with an internal endpoint provided to them that makes reauth automatic.

  • If an integrator is not using the endpoint or has not updated to OAuth2 users will need to re-auth.

What to do?
We will email impacted customers with instructions. But to view all integrations inside your portal and re-auth an integration that has switched to OAuth2.

Why it matters
There may still be integrations using built on OAuth1. Come January those integrations will break. There may also be users who are using an integration that is on OAuth2 and just need to re-auth before that date to maintain functionality. Make sure to do so before the migration date to keep your integrations working.